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PowerTeacher Gradebook is a powerful tool for teachers. Teachers
can use the gradebook to access student information, create and
copy assignments across like classes, record assignment scores,
access mean, median, and mode scores for assignments,
communicate with students and parents, and much more.

Launching the Gradebook

Use the new gradebook launch method to avoid Java updates.
After you complete the installation steps for the Gradebopk
application, you can choose to launch the gradebook from
PowerTeacher or from an application on your desktop.

Launching from PowerTeacher

To access PowerTeacher Gradebook, begin by signing in to
PowerTeacher.

1. Navigate to your PowerTeacher server address

2. Enter the username and password assigned to you by your
PowerSchool administrator and click Sign In

School: Apple Grove High School

Navigation 8
PR Current Classes

Daily Bulletin
Schedule N\ #
3(A)  English Surve! ? N¢
Staff Directory ) 9 Y @ it /\
Meals 3(B) AP American Lit and Comp =2 E % DY
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Personalize

3. Choose a different school if you are affiliated with more than
one school in the district

4. In the navigation menu, click Launch

If you have not run the installer, you’ll need to do that
before trying to launch the gradebook.

Launching from the Desktop

To access PowerTeacher Gradebook using the desktop shortcut,
complete the following steps.

1. On your local machine, double-click Gradebook Login

- PowerTeacher

GRADEBOOK

Sign In

School: | Apple Grove High School A

Username:

Password:

Quit | | signin |

PowerTeacher Portal

Choose a different school, if needed
Enter your username and password
4. Click Sign In

If an error appears instead of the gradebook, verify that you
have completed all the installation steps.
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Accessing Student Information

Although you can access student information in PowerTeacher, the
gradebook contains additional student information, such as the
grade scale by which you grade each student and any personal
notes you write about students. To access a student’s information
in the gradebook:

1. In the Classes pane, select a section

2. Click Student Info, then double-click the name of a
student

On the student's information pane, notice several icons near
the top of the pane. The icons alert you to important things
you need to know about your student, like medical
conditions, family situations, or disciplinary considerations.
Click each alert icon to learn more about your student.

Howard, Erin

@ Il

Student | ExtraClass Columns | Teacher Personal Note

L

Name: Howard, Erin Student Number: 82
‘6' Gender: F Grade Level: 11
e [
| 2;

Birthday: 09/04/1997 Grade Scale: Default

Student Home Phone: 916-555-3544 Student Email:

Mother: Jillian Howard Father: Davis Howard

Guardian Email: momanddad@PSSIS.com

EmergencyOne: Colby Thomas
Phone: 281-555-1509

EmergencyTwo Phone: 916-555-3205

3. Click any of the phone number links to enlarge the number

4. Send an email to a parent by clicking the Guardian Email
link, select Email, and complete the email message

Alternatively, click the Guardian Email link, select Copy to
copy the email address, and then paste the address into
your email program.

5. Click Grade Setup to use the Grade Scale menu
Apply either the default scale or a custom grade scale to the
selected student.

6. Use the Extra Class Columns tab to record data for columns
you personalize in your gradebook
The columns listed reflect the custom columns you create,
except for the Preferred Name field.

7. Use the Preferred Name column to record the name the
student prefers to be called

For example, a student named Elizabeth may prefer to be
called Liz. Learn more about the custom columns in the next
section.

8. Use the Teacher Personal Note tab to record private
information that only you have access to

Personalizing Class Columns

Personalize student information using the extra class columns. Edit
or create columns to record book numbers, locker numbers, lab
partners, or emergency contacts for each of your students. There is
no limit to the number of extra class columns you can create.

1. In the upper part of the pane, click Extra Class Columns
2. Select an existing column and click Edit

Click Add to add any new columns.
Enter a column name and description
4. Click OK > Close

Enter information for several students
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6. Click and drag the column headings to rearrange the
columns

Use column headings to change the sort order of the
students.

7. Click Save

Changing Student Display Settings

Use Preferences to format how students appear on your
Scoresheet. For example, display preferred names for students on
the Scoresheet.

1. Open the Tools menu (Windows) or the PowerTeacher
Gradebook menu (Mac), and select Preferences

2. Click Student

| Comment Bank = Grading = Mail = Score Codes = Section = Spell Check = Standards

Student Name Display: | Last, First + | Example: Smith, John

Use Preferred Name* when available
Use Preferred Name* on reports
*Preferred names are entered on the Student Info tab

Sort Students By: | Last Name al

_| Add newly enrolled students to the bottom
Hide pre-registered students

*Teacher Defined Order is set on the Student Info tab. Click the
"My Order" column header, then drag-and-drop students to the desired order.

3. From the Student Name Display menu, choose how the
student's complete name will appear

4. Check Use Preferred Name* when available

If the student doesn't have a preferred name, his or her full
name will appear.

5. Check Use Preferred Name* on reports to print the
preferred name instead

6. Use the Sort Students By menu to change the default sort
order of your students

7. Click OK

Adding Class Content

The Class Content pane contains three modes: Class Info, School
Content, and My Content. You can view and edit basic class
information for the selected class in Class Info mode. The content
modes contain links to websites and resources on the web. Your
PowerTeacher administrator provides resources in School Content.
Add online resources you’d like to use in My Content mode.

To add a link to your content:
1. Click Class Content > My Content
2. Below the list, click the + sign
3. Enter the name and address of the website
4. Choose a content type and group
Web Site is the default content type. If you're linking to a

document that resides on your district server, select PDF or
Word Doc to match.

5. Enter a description of the resource

6. Click Save, and the link will appear on the My Content page

- Apple Grove High S::Mu

E w \:s u ! =4

Scoresheet  Assignments  StudentInfo  Grade Setup Class Content Reports Attendance

Reporting Term 1 Mode: | Class Info H School Content |m

My ..A Name Group Type Address Description

1 Teachers First @ f{ Group Web Site www.teachersfirst.com TeachersFirst: The web resource by teachers, for teachers

Thinkfinity | § No Group !hinkfinity.org CCSS, resources cross-curricular
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To add a link to your class description:
1. In the Classes pane, select a section
Click Class Content > Class Info
Enter a description
Click + link
Select the link you wish to add, then click OK

o vk wWwN

Make changes to the description, if needed, and click Save

The class description and any links you have added are
visible in the PowerSchool Student and Parent Portals.
Students and parents can click the links to access the
website or other online resources.

To change the name of one of your sections as it appears in the
Classes pane:

1. Select a section
2. Click Class Content > Class Info
3. For Custom Display Name, enter a new name
4. Click Save
To display the new class section name in your list of sections:

1. From the Tools menu (Windows) or the PowerTeacher
Gradebook menu (Mac), select Preferences

2. Click Section
3. Select Custom Display Name > OK

Creating Categories

To save you time, the gradebook contains four pre-defined
categories: Homework, Project, Quiz, and Test. You can access
these categories, and any you create, in each class you teach. To
create a new category:

1. From the Tools menu, select Categories

2. In the lower-left corner, click +

Give the category a name, abbreviation, and a default
number of points possible

4. Choose a color, score type, and publish assignment option

Check Include in Final Grade, if appropriate, and add a
description

e 00 Create Assignment Category

Create Assignment Category

Name: | Behavior

Abbreviation: |BH

Color: | [\ Olive A

These options will be applied as defaults to any new assignments when
created for this category.

Points Possible: |10
Extra Points: |0

Score Type: Points =

Include in Final Grade: [g

“

Publish Assignment: Immediately
On Date:

Days Before Due: |0

Publish Scores: [g

6. Click OK to save the categories you created or modified

To add another category, click +. Click - to delete the
selected category. To edit an existing category, double-click
it and change any of the values.
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Entering Assignments

You can add assignments to the gradebook anytime during the
school year, as well as copy assignments from a previous school
year or term. To create an assignment in the gradebook:

1.
2.
3.

10.

Click Assignments, and below the Assignment list, click +
Enter a name, abbreviation, category, and score type

Enter a number of points possible, any extra points, weight,
and date due

Check Include in Final Grade, unless the assignment is a
draft or non-graded activity

Add a description so students and parents can view what is
required for this assignment

Assignment (L Publish )/ Standards )
Name: | Poetry Book Abbreviation: | Poetry Book

Category: | ] Project Score Type: | Points

Points Possible: 100 Extra Points: 0 Max: 100 Weight: | 1.00

Date Due: 01/08/2014 Include in Final Grade: [g

Description: |

Click the Publish tab

Choose to publish the assignment immediately, on a specific
date, or a number of days before it is due

Check Publish Scores to show scores in the PowerSchool
Student and Parent Portals

Click the Standards tab

If standards are associated to this class, select the
standards aligned to this assignment

11.Click Save

The assignment will appear in the assignment list as well as

the Scoresheet.

Copying Assignments

You can copy assignments from one class to another, from one
school to another when you teach at difference schools, or from
current or previous terms. Use the Current Classes menu in the
Classes pane to select previous classes. Select to copy one
assignment, several assignments, or all assignments.

1.

Select the class that contains the assignment(s) you want to
copy

From the Tools menu, select Copy Assignments

Check the assignments you want to copy, and click Next
The Copy Assignments window defaults to the current term,
but you can also choose previous or future school years

If you teach classes at different schools, you’ll have an
additional menu for school. Choose a different school to
copy the assignment(s) to one of those classes.

Check the class or classes to copy the assignments to
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6. Choose to keep the existing due date, assign today’s date,
or enter a custom date

8 00 Copy Assignments

Copy Assignments
Copy assignments to the selected classes.

Copy Assignment: CH 8 reading from Class: 3(A) English Survey
13-14 to the selected classes.

| Apple Grove High School =
| Semester 2 =
| | Classes

(J ﬁ] same class
E] 3(B) AP American Lit and Comp 13-14

™ [ 4(®) English Survey 13-14

Due Date: | Existing | 12/08/2013

& | Back | | Cancel | oK

7. Click OK

Entering Scores

When entering scores, make sure to use the type of score that you
set up when you created the assignment: numbers for points and
percentages or letters for letter grades. Enter scores manually or
use the quick-entry method.

1.

Click Scoresheet, and click the cell that is the intersection
of the row containing the student’s name and the column of
the assignment

Enter the score, such as 25 or a

Press Enter to advance to the next student or Tab to
advance to the next assignment

When you are finished entering scores, click Save

27 N
_‘_\;: f | ) - )
Sy !b?/ A \©®
=kt L] E \
0 Scoresheet ~ Assignments  StudentInfo  Grade Setup Class Content Reports
Reporting Term: | S2 3|  Mode: m |W|[
(5]
S2 In Progress I E S‘ Pos S’ .
=l .S m £
® S "<
gso 23
© S ] o c
wv
Students (29) (S2) Final Grade T 5 & = \I) e
Bennett, Cody ©C 75% 90/120 - 14
Dansie, Amanda QA 100% 120/120 - 20
Gollner, Kimberly D A- 93% 1127120 | - 17
Grim, Jesse QA 97% 116/120 - 20
Holt, Brian 2 A- 93% 111/120 - 19
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Locking the Gradebook

When you're ready to end your PowerTeacher Gradebook session,
sign out and close the gradebook. If you're in the middle of a task
and don’t want to end your session, lock the gradebook. To keep

your information secure, lock your gradebook two different ways:

1. Use the keyboard shortcut CTRL-L (Windows) or
Command-L (Mac), or navigate to the File menu, and
select Lock Gradebook

PowerTleacher

GRADEBOOK

Password:

|

2. The lock screen appears, covering the entire gradebook and
keeping student information private

3. If you want to unlock the gradebook, enter the same
password you use to sign in to PowerTeacher, and click
Unlock
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